Mi Blog

No te olvides seguirme en Facebook.

Tan solo tienes que hacer click en Me Gusta

 

 

x

⋆ Enrutamiento entre VLANs con Packet Tracer

⋆ Enrutamiento entre VLANs con Packet Tracer

(Tiempo estimado: 5 - 9 minutos)

Con este tutorial aprenderéis a configurar el enrutamiento entre VLANs con el software de simulación de redes Packet Tracer de Cisco.En este tutorial se han omitido muchos de los pasos básicos de configuración, por lo que si no estáis familiarizados con Packet Tracer , es posible que dudéis en alguno de ellos, aunque son pasos y configuraciones sumamente sencillos..

Si queréis aprender como realizar el enrutamiento entre VLANs, seguid leyendo!

 

 

¿QUÉ ES UNA VLAN?

Una VLAN, acrónimo de virtual LAN (red de área local virtual), es un método para crear redes lógicas independientes dentro de una misma red física. Varias VLAN pueden coexistir en un único switch físico o en una única red física. Son útiles para reducir el dominio de difusión y ayudan en la administración de la red, separando segmentos lógicos de una red de área local (los departamentos de una empresa, por ejemplo) que no deberían intercambiar datos usando la red local (aunque podrían hacerlo a través de un enrutador o un conmutador de capa OSI 3 y 4).

 

 

Enrutar entre VLANs es posible

 

 

1.- ELEMENTOS UTILIZADOS EN ESTE TUTORIAL

  • Packet Tracer 6.0.1

 

 

2.- ESQUEMA DE RED

El esquema de la red que queremos emular, es el que se ve en la imagen siguiente. Tenemos 2 oficinas o aulas con N equipos conectados en cada una de ellas (en este caso hay 2 equipos en cada oficina). En cada oficina hay un switch, y cada switch se conecta a un switch central. Por último, el switch central se conecta al router de acceso a Internet. Cada oficina está en una VLAN, y a diferencia de otros ejemplos, queremos que los equipos de una VLAN se puedan conectar con equipos de otra VLAN por el motivo que sea.

El esquema de red es el siguiente:

Enrutamiento entre VLANsEsquema de red

 

 

En al siguiente tabla se muestra el direccionamiento que se ha usado para cada uno de los equipos del esquema de red. Hay que prestar especial atención a las VLANs en las que está cada uno de los elementos del esquema:

Enrutamiento entre VLANsDireccionamiento de Red

 

 

3.- EQUIPOS CLIENTES

Añadiremos los 4 equipos clientes (PCs) y configuraremos su interfaz de red con la dirección IP y la máscara de red de la tabla del punto 2. Deberemos prestar atención a la puerta de enlace de cada zona ya que es diferente. La puerta de enlace de cada oficina es el mismo router (ROUTER0) pero en dicho equipo configuraremos varias IPs virtuales.

 

 

4.- SWITCHES

La configuración de los switches es sumamente sencilla. Debemos poner todos los puertos (al menos los que tienen cable) en la misma VLAN. Se puede hacer de forma gráfica (mucho mas lento) o a través de comandos. Para hacerlo de forma rápida cambiaremos los puertos (todos) a su correspondiente VLAN:

SWITCH1:

Switch>
Switch>en
Switch#conf t
Switch(config)#vlan 10
Switch(config-vlan)#name VLAN10
Switch(config-vlan)#int r f0/1-24
Switch(config-if-range)#switchport mode access
Switch(config-if-range)#switchport access vlan 10

 

 

SWITCH2:

Switch>
Switch>en
Switch#conf t
Switch(config)#vlan 20
Switch(config-vlan)#name VLAN20
Switch(config-vlan)#int r f0/1-24
Switch(config-if-range)#switchport mode access
Switch(config-if-range)#switchport access vlan 20

 

 

SWITCH3 (CENTRAL):

Switch>en
Switch#conf t
Switch(config)#vlan 10
Switch(config-vlan)#name VLAN10
Switch(config-vlan)#vlan 20
Switch(config-vlan)#name VLAN20
Switch(config-vlan)#vlan 30
Switch(config-vlan)#name VLAN30
Switch(config-vlan)#int f0/24
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 10
Switch(config-if)#int f0/23
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 20
Switch(config-if)#int f0/1
Switch(config-if)#switchport mode trunk
Switch(config-if)#switchport nonegotiate
Switch(config-if)#switchport access vlan 30

 

 

5.- ROUTER

La configuración del router también es muy sencilla. Se deben configurar 2 interfaces virtuales con las IP correspondiente. El comando "no sh" sirve para que las interfaces de red se levanten cuando el equipo arranca:

A continuación dejo la configuración en modo consola para el router:

ROUTER0:

Router#en
Router#conf t
Router(config)#int f0/0.10
Router(config-subif)#encapsulation dot1Q 10
Router(config-subif)#ip add 192.168.0.1 255.255.255.0
Router(config-subif)#no sh
Router(config-subif)#int f0/0.20
Router(config-subif)#encapsulation dot1Q 20
Router(config-subif)#ip add 192.168.1.1 255.255.255.0
Router(config-subif)#no sh
Router(config-subif)#int f0/0
Router(config-if)#no sh

 

 

6.- PROBAR EL ENRUTAMIENTO ENTRE VLANS

Para comprobar que el routing está funcionando correctamente, entraremos en la Terminal de PC0 (192.168.0.100) y haremos Ping por ejemplo al equipo PC3 (182.168.1.101). Los paquetes irán primeramente por el camino mas óptimo según el protocolo BGP.

Aquí os dejo un ejemplo donde se puede ver que funciona perfectamente:

Enrutamiento entre VLANsEnrutamiento entre VLAN10 y VLAN20

Podemos comprobar con el comando PING desde uno de los equipos, si los paquetes llegan a su destino:

Enrutamiento entre VLANsPing desde PC0 a PC3

 

 

Aquí os dejo un ejemplo donde se puede ver que funciona perfectamente:

Enrutamiento entre VLANsEnrutamiento entre VLAN20 y VLAN10

Podemos comprobar con el comando PING desde uno de los equipos, si los paquetes llegan a su destino:

Enrutamiento entre VLANsPing desde PC2 a PC1

¿Sencillo verdad?

 

ENJOY!


Raúl Prieto Fernández

Sitio Web: raulprietofernandez.net

Si quieres ir rápido, ve solo. Si quieres llegar lejos, ve acompañado.

Comentarios  

David Arce
# David Arce 15-02-2020 11:05
Muy buen post Raúl (y muy buen blog), lo he utilizado con mis alumnos de ASIR y lo han entendido a la perfección.
Un saludo, (Tu ex-compi de la CDN)
Responder
Raúl Prieto Fernández
# Raúl Prieto Fernández 18-02-2020 11:41
Hola David!:

Muchas gracias !

:D
Responder
Vanessa
# Vanessa 01-09-2020 20:11
Raúl si al hacer un ping entre PcO y Pc2, a que puede ser debido si las Vlan están definidas y los puertos también. Al modo Trunk??
Responder
Raúl Prieto Fernández
# Raúl Prieto Fernández 06-09-2020 15:44
Hola Vanessa:

Pues podría ser por diferentes motivos. ¿Puedes colgar el fichero de Packet Tracer en algún lado para echarle un vistazo?

Saludos
Responder
Randall Jiménez G
+1 # Randall Jiménez G 18-03-2020 17:27
Excelente explicaiones, muchas gracias por compartir su conocimiento
saludes
Responder
Raúl Prieto Fernández
# Raúl Prieto Fernández 18-03-2020 17:44
Hola Randall Jiménez G:

Me alegra que te haya servido de ayuda.

Saludos
Responder
Alexandra
# Alexandra 28-03-2020 01:30
Hola!! quisiera hacer el enrutamiento entre dos vlan iguales que estan conectadas a distinta switchs, como seria?

Gracias!!
Responder
Raúl Prieto Fernández
# Raúl Prieto Fernández 08-04-2020 12:19
Hola Alexandra:

No entiendo exactamente tu pregunta. En el tutorial es exactamente eso lo que está explicado, cómo enrutar tráfico entre 2 vlans, cada una de ellas en un switch diferente.
Responder
Albert
# Albert 27-04-2020 23:31
Buenas, mi pregunta es: ¿Cómo sería la configuración (comandos) del Router si tengo creadas dos VLAN, pero en dos switchs independientes? Es decir, sin necesidad de crear subinterfaces, ya que tengo un switch principal para cada VLAN conectado directamente al Router. Gracias.
Responder
yo
# yo 30-04-2020 21:25
que hace el comando "no sh"???
Responder
Raúl Prieto Fernández
# Raúl Prieto Fernández 01-05-2020 10:53
Hola yo:

El comando "no sh" es la abreviatura de "no shutdown" y lo que hace es que a interfaz de red esté siempre levantada, incluso cuando el equipo se reinicia.

Saludos
Responder
yo
# yo 30-04-2020 21:26
que significa el comando "no sh"??
Responder
Raúl Prieto Fernández
# Raúl Prieto Fernández 01-05-2020 10:53
Hola yo:

El comando "no sh" es la abreviatura de "no shutdown" y lo que hace es que a interfaz de red esté siempre levantada, incluso cuando el equipo se reinicia.

Saludos
Responder
Ricardo
# Ricardo 06-05-2020 21:56
Cual es el objetivo de la Vlan 30
Responder
Raúl Prieto Fernández
# Raúl Prieto Fernández 07-05-2020 16:35
Hola Ricardo:

Pues básicamente los elementos del equipamiento de Networking de "cabecera" en una red suelen estar en una VLAN dedicada para ellos en exclusiva, por eso la vlan 30. También porque sirve para evitar ataques de etiquetado doble en las VLANs y por que cada segmento de red debe tener una lógica y su propia VLAN para tenerlo todo bien organizado.

Espero haberte aclarado las dudas.

Saludos
Responder
luis
# luis 13-07-2020 03:59
hola amigo, necesito ayuda para resolver lo siguiente:

tengo un equipo con la ip 192.168.10.45 conectado a un router ip 192.168.10.1 dicho router se conecta a otro router remotamente a otra sede ip 192.0.2.1 y este se conecta a un switch con 2 vlan, vlan 1:192.0.2.100 y vlan 10: 10.10.10.20, mi pregunta es como configurar el switch para que pueda recibir ping desde 192.168.10.45, espero haberme explicado, es una practica de packet tracer, espero me puedas ayudar, gracias.
Responder
Pablo
# Pablo 07-08-2020 01:27
¿Esto funcionaria para el caso de las impresoras?
Por ejemplo en un edifico de 2 pisos están distribuidas 6VLAN

En el piso 1 o planta baja hay un switch con usuarios de las VLAN 10,20,40 y 1 impresora.

En el segundo piso o planta alta esta otro switch con usuarios de la VLAN 10,30 y 50 y dos impresoras.

Y las 3 impresoras se encuentran en la VLAN 60.
Con este ejemplo las VLAN 10,20,30,40 y 50 se comunicarían con la VLAN 60 para el envío de archivos a impresión o desde las impresoras enviar los escaneos a las PCs que así lo requieran.
Responder
Raúl Prieto Fernández
# Raúl Prieto Fernández 06-09-2020 15:58
Hola Pablo:

Pues siempre que el hardware de red permita realizar las configuraciones explicadas en este tutorial, no debería haber problema.

Es decir, los equipos de la VLANs 10,20,30,40 y 50 deberían ser capaces de imprimir en cualquiera de las 3 impresoras de la VLAN60.

Pero cuidado, porque con e ejemplo explicado aquí, todos los equipos verán a todos los demás equipos de las demás VLANs, y es posible que eso no sea lo que necesites. Quizás tengas que implementar alguna política de FW para evitar ese "problema".

Saludos
Responder
mario perea rodrigue
# mario perea rodrigue 08-10-2020 23:13
ing como seria la configuracion, pero para que el router reparta las direcciones mediante DNS, y no aplicar ninguna IP a los PC, sino dejarlas dinamicas, con el mismo ejercicio que pulico ud, aqui pero ahora que sea mediante DNS.

mil gracias
Responder
mario perea rodrigue
# mario perea rodrigue 08-10-2020 23:15
ing. Raul, como seria usando este mismo ejemplo de VLAN con IP Estatica, pero ahora que sea el router quien haga el enrutamiento, es decir mediante Servidor DNS.

mil gracias
Responder
JEAN PIERE
# JEAN PIERE 12-11-2020 05:14
HOLA SI QUISERA PONER UN EQUIPO QUE PUEDA ESTAR EN LA VLAN 10 Y EN LA VLAN 2O
Responder

Escribir un comentario

Código de seguridad
Refescar