Mi Blog

No te olvides seguirme en Facebook.

Tan solo tienes que hacer click en Me Gusta

 

 

x

Cómo crear Backups y enviarlos por Email con MikroTik y RouterOS

Cómo crear Backups y enviarlos por Email con MikroTik y RouterOS

(Tiempo estimado: 5 - 9 minutos)

Generar las copias de seguridad y el envío automático de las mismas es muy sencillo en los equipos MikroTik y RouterOS. Las copias de seguridad se pueden enviar por email, ftp, sftp etc... En este tutorial os enseñaré a hacerlo a través de email ya que es muy sencilla su configuración y funciona estupendamente bien.

Seguid leyendo y os enseñaré a generar y enviar automáticamente las copias de seguridad de los equipos MikroTik y RouterOS...

⬇️ Conoce el hardware que utilizo ⬇️

🔥 HAZ CLICK AHORA 🔥

 

 

¿QUÉ ES UN BACKUP?

Una copia de seguridad, respaldo, copia de respaldo o copia de reserva (en inglés backup y data backup) es una copia de los datos originales que se realiza con el fin de disponer de un medio para recuperarlos en caso de su pérdida. Las copias de seguridad son útiles ante distintos eventos y usos: recuperar los sistemas informáticos y los datos de una catástrofe informática, natural o ataque; restaurar una pequeña cantidad de archivos que pueden haberse eliminado accidentalmente, corrompido, infectado por un virus informático u otras causas; guardar información histórica de forma más económica que los discos duros y además permitiendo el traslado a ubicaciones distintas de la de los datos originales; etc.

El proceso de copia de seguridad se complementa con otro conocido como restauración de los datos, que es la acción de leer y grabar en la ubicación original u otra alternativa los datos requeridos. La pérdida de datos es muy común, el 66 % de los usuarios de Internet han sufrido una seria pérdida de datos en algún momento.

 

 

Las copias de seguridad deben guardar en otro equipo

 

 

1.- ELEMENTOS NECESARIOS PARA ESTE TUTORIAL

 

 

2.- CREAR EL SCRIPT DE BACKUP Y ENVÍO DE EMAIL

Lo primero que debemos hacer es crear el script que se encargará de realizar el backup y el posterior envío por email. Para ello iremos desde "System->Scripts":

Backups Email MikroTikCrear script

 

 

Para crear el script debemos ir a la pestaña "Scripts" y luego hacer click en + para comenzar a crear el script:

Backups Email MikroTikCrear script

 

 

Debemos tener claro los permisos disponibles para los scripts. No todos son necesarios pero aquí dejo cada uno de ellos:

  • ftp - Acceder remotamente a un ftp y enviar y recibir ficheros desde el router
  • password - cambiar contraseñas
  • policy - gestionar políticas de usuario, añadir y eliminar usuarios
  • read - leer la configuración del router
  • reboot - reiniciar el router
  • sensitive - permite cambiar parámetros "hide sensitive"
  • sniff - puede ejecutar sniffer, torch etc...
  • test - puede ejecutar ping, traceroute, bandwidth test...
  • write - puede cambiar la configuración

 

 

El código del script es el siguiente (posiblemente solo tendréis que cambiar la dirección de Email):

# Start Variables Definition
:local routerName [/system identity get name];
:local dateNow [/system clock get date];
:local timeNow [/system clock get time];
:local sendTo "Esta dirección de correo electrónico está siendo protegida contra los robots de spam. Necesita tener JavaScript habilitado para poder verlo.";
:local subject "\F0\9F\93\A6 BACKUP: [ $routerName ] [ $dateNow ]";
:local body "$routerName - Backup file attached in this Email\nDate: $dateNow and Time: $timeNow";
:local file "$routerName_file.backup";
:local password "P4SSw0rd#";
# End Variables Definition

# Start Main Script
# & Make Backup and Send Email
/system backup save name=$file password=$password
/tool e-mail send to=$sendTo body=$body subject=$subject file=$file;
# End Main Script

 

 

Si omitimos el password, el backup irá sin cifrar y todo el contenido, contraseñas, tokens etc serán accesibles por cualquier persona... ¡Es recomendable usar siempre una contraseña!

Crearemos el script con el nombre "DoBackupAndEmail", seleccionaremos read, write, policy, test y sensitive. Pegaremos el código del script y luego haremos click en "OK":

Backups Email MikroTikCopiar y pegar el código

3.- PROBAR EL SCRIPT DE FORMA MANUAL

Para probar el script, ejecutaremos el siguiente comando. El script no debe mostrar ningún error, tal y como se ve a continuación:

# Start Main Script
# & Make Backup and Send Email
/system backup save name=$file password=$password
/tool e-mail send to=$sendTo body=$body subject=$subject file=$file;
# End Main Script

 

 

4.- PROGRAMAR EL SCRIPT PARA SU EJECUCIÓN AUTOMÁTICA

Para programar el script, debemos ir al programador de tareas desde "System->Scheduler":

Backups Email MikroTikProgramador de tareas

 

 

Añadimos una nueva tarea haciendo click en +:

Backups Email MikroTikAñadir tarea

 

 

Crearemos la tarea "SendBackupEmail", configuraremos las horas a las que queremos que se ejecute (1 vez al día todos los días a las 12:20) y seleccionaremos readwritepolicytest y sensitive. En la parte de abajo debemos escribir lo que queremos ejecutar cuando se ejecuta la tarea. En este ejemplo queremos ejecutar el script creado en pasos anteriores.

/system script run DoBackupAndEmail

 

 

En la imagen siguiente se ve la configuración final:

Backups Email MikroTikTarea programada

 

 

En el listado de tareas podremos ver cuantas veces se ha ejecutado la tarea con el programador de tareas:

Backups Email MikroTikListado de tareas

 

 

5.- COMPROBAR QUE EL BACKUP SE RECIBE

Para comprobar que el email ha llegado a la hora programada, abriremos el email para comprobar que ha llegado correctamente:

Backups Email MikroTikEmail recibido

 

 

El email ha llegado correctamente junto al backup cifrado:

Backups Email MikroTikEmail

 

 

ENJOY!


⬇️ Conoce el hardware que utilizo ⬇️

🔥 HAZ CLICK AHORA 🔥
Raúl Prieto Fernández

Sitio Web: raulprietofernandez.net

Si quieres ir rápido, ve solo. Si quieres llegar lejos, ve acompañado.

No tienes permisos para escribir comentarios. Debes autenticarte con Facebook, Linkedin, Twitter o Google.