Mi Blog

Las Mejores Ofertas de Amazon

hack Disco Duro Seagate Barracuda
hack Sandisk Pendrive
hack Monitor HP 27''
hack Disco Duro Kingston SSD

No te olvides seguirme en Facebook.

Tan solo tienes que hacer click en Me Gusta

 

 

x

Cómo limitar el ancho de banda con MikroTik y RouterOS

Cómo limitar el ancho de banda con MikroTik y RouterOS

(Tiempo estimado: 5 - 10 minutos)

Limitar el ancho de banda con MikroTik y RouterOS es muy sencillo y se puede realizar de forma gráfica ó desde línea de comandos. Existen muchas formas de realizar el control del ancho de banda de los usuarios, algunas son bastante complejas de entender y configurar, pero en este tutorial empezaremos con lo más básico.

Seguid leyendo y os enseñaré la forma mas sencilla de limitar el ancho de banda de los clientes de vuestra red...

 

 

¿QUÉ SON LAS COLAS SIMPLES?

Las colas simples en MikroTik son una forma sencilla de limitar el consumo de recursos de red, discriminando por direcciones IP o redes, puede implementar características de calidad de servicio como el encolar el tráfico de aplicaciones punto a punto o conocido como peer to peer, aplicarlas en tiempos determinados, priorizar redes o direcciones IP, utilizar marcado de maquetes y limitar el tráfico en diferentes direcciones.

En el caso de que se tenga una gran cantidad de reglas o se tenga la necesidad de realizar un compartimiento de canales, no es recomendable utilizar colas simples ya que estas se irán cumpliendo una por una, en el orden que se tenga automáticamente establecido.

 

 

Las colas simples son la forma mas sencilla de limitar el tráfico

 

 

1.- ELEMENTOS NECESARIOS PARA ESTE TUTORIAL

  • MikroTik o equipo con RouterOS conectado a Internet y funcionando
  • Internet (no es obligatorio)

 

 

2.- CONFIGURAR UNA COLA SIMPLE PARA UNA IP

Si realizamos una prueba de velocidad desde el equipo con la IP 10.10.10.2 ANTES de crear la regla de control de velocidad, veremos que se obtiene la siguiente velocidad:

Colas simples MikroTikColas simples con MikroTik

 

 

Para configurar las colas desde el entorno gráfico es tan sencillo como ir a "Queues->Simple Queues":

Colas simples MikroTikColas simples por IP

 

 

Para crear una cola para una determinada IP 10.10.10.2 con un límite de Download (descarga) de 4Mbits/s y de Upload (subida) 2Mbits/s rellenaremos los siguientes campos y pulsaremos "OK":

Colas simples MikroTikColas simples con MikroTik

 

 

Ahora, si realizamos una prueba de velocidad desde el equipo con la IP 10.10.10.2 de crear la regla de control de velocidad, veremos que se obtiene la siguiente velocidad limitada por la cola creada en el MikroTik:

Colas simples MikroTikVelocidad limitada para una IP

3.- CONFIGURAR UNA COLA SIMPLE PARA UNA RED

Si en lugar de crear una cola para una IP determinada, creamos una cola para una red, estaremos limitando a todos los equipos dentro de esa red. El tráfico se comparte entre todos los dispositivos de dicha red. Si queremos limitar el tráfico total de la red 10.10.10.0/24 a Download (descarga) 10Mbits/s y de Upload (subida) 5Mbits/s completaremos los siguientes campos y luego haremos click en "OK":

Colas simples MikroTikCola simple en una Red con MikroTik

 

 

Si hacemos el test de velocidad desde un equipo de la red, veremos que el tráfico se limita. Sin embargo, si el 50% del tráfico está siendo usado por otros equipos, obtendremos el 50% del resultado mostrado a continuación. Recuerda que el ancho de banda se comparte entre todos los equipos:

Colas simples MikroTikVelocidad limitada para una red

 

 

4.- CONFIGURAR UNA COLA SIMPLE POR INTERFAZ DE RED

Si queremos limitar el tráfico total para una interfaz de red, por ejemplo para ether2, introduciremos los siguientes datos y haremos click en "OK":

Colas simples MikroTikColas simples por interfaz de red

 

 

5.- CREACIÓN DE COLAS DESDE COMANDOS

Para crear las colas desde la terminal, ejecutaremos los 3 comandos siguientes:

[admin@MikroTik] > /queue simple add name="Invitado1" target="10.10.10.2" max-limit=2M/4M
[admin@MikroTik] > /queue simple add name="Empleados" target="10.10.10.0/24" max-limit=5M/10M
[admin@MikroTik] > /queue simple add name="lan" target=ether2 max-limit=50M/50M

 

 

Con el siguiente comando podemos ver la configuración actual de las colas simples de MikroTik:

[admin@MikroTik] > /queue simple print 
Flags: X - disabled, I - invalid, D - dynamic
0 name="Invitado1" target=10.10.10.2/32 parent=none packet-marks="" priority=8/8 queue=default-small/default-small limit-at=0/0 max-limit=2M/4M burst-limit=0/0
burst-threshold=0/0 burst-time=0s/0s bucket-size=0.1/0.1

1 name="Empleados" target=10.10.10.0/24 parent=none packet-marks="" priority=8/8 queue=default-small/default-small limit-at=0/0 max-limit=5M/10M burst-limit=0/0
burst-threshold=0/0 burst-time=0s/0s bucket-size=0.1/0.1

2 name="lan" target=ether2 parent=none packet-marks="" priority=8/8 queue=default-small/default-small limit-at=0/0 max-limit=50M/50M burst-limit=0/0
burst-threshold=0/0 burst-time=0s/0s bucket-size=0.1/0.1

 

 

Tenemos que recordar que las colas se leen de forma secuencial, es decir, si primero se cumple la regla 2, aunque la 3 también se cumpla se "ejecutará" la regla 2.

 

 

6.- INDICADORES DE COLORES

Las colas están representadas por un icono de color. En función del trafico utilizado el icono cambia a uno u otro color. A continuación se muestran los baremos:

  • 0% - 50% tráfico utilizado –  VERDE 
  • 51% - 75% tráfico utilizado –  AMARILLO 
  • 76% - 100% tráfico utilizado –  ROJO 

Colas simples MikroTikColas simples utilizando entre 51%-75%

 

 

En la imagen siguiente se puede ver que la cola llamada "empleados" que engloba a toda la red 10.10.10.0/24 menos la IP 10.10.10.2/32 está utilizando entre el 76%-100% de ancho de banda:

Colas simples MikroTikColas simples utilizando entre 76%-100%

 

 

ENJOY!


Raúl Prieto Fernández

Sitio Web: raulprietofernandez.net

Si quieres ir rápido, ve solo. Si quieres llegar lejos, ve acompañado.

Escribir un comentario

Código de seguridad
Refescar