Mi Blog

No te olvides seguirme en Facebook.

Tan solo tienes que hacer click en Me Gusta

 

 

x

⋆ Cómo enviar mensajes desde MikroTik y RouterOS a Telegram

⋆ Cómo enviar mensajes desde MikroTik y RouterOS a Telegram

(Tiempo estimado: 4 - 7 minutos)

Enviar mensajes y alertas desde MikroTik a un grupo de Telegram es sumamente sencillo y útil para estar informado de posibles anomalías o problemas en una red gestionada por MIkroTik y RouterOS. En este tutorial os enseñaré a crear tanto el Bot y el grupo de Telegram y también a enviar un mensaje de pruebas desde MikroTik a Telegram. Todo esto se puede combinar con el programador de tareas y así poder enviar al grupo los datos que mas nos interesen. Todo esto siempre en función de vuestras necesidades, por supuesto.

Seguid leyendo y os enseñaré a enviar notificaciones a Telegram desde MikroTik y RouterOS...

 

 

¿QUÉ ES TELEGRAM?

Telegram es una aplicación de mensajería enfocada en la velocidad y seguridad, es súper rápida, simple y gratuita. Puedes usar Telegram en todos tus dispositivos al mismo tiempo. Tus mensajes se sincronizan a la perfección a través de cualquiera de tus teléfonos, tablets o computadoras. Telegram tiene más de 500 millones de usuarios activos mensuales y es una de las 10 apps más descargadas del mundo.

Con Telegram, puedes enviar mensajes, fotos, videos y archivos de cualquier tipo (doc, zip, mp3, etc.), como también crear grupos de hasta 200.000 personas o canales para hacer difusiones a audiencias ilimitadas. Puedes escribir a tus contactos del teléfono y encontrar personas a través de sus nombres de usuario. Como resultado, Telegram es como el SMS y el correo electrónico combinados, y puede satisfacer todas tus necesidades de mensajería personal o de negocios. Además, ofrece llamadas de voz y videollamadas con cifrado end-to-end, así como chats de voz en grupos que permiten miles de participantes.

Web: www.telegram.org

 

 

MikroTik puede enviar mensajes y alertas a un canal de Telegram

 

 

1.- ELEMENTOS NECESARIOS PARA ESTE TUTORIAL

  • MikroTik o equipo con RouterOS
  • Cuenta en Telegram
  • Internet

 

 

2.- CREAR EL BOT Y EL CANAL EN TELEGRAM

Lo primero que debemos hacer es crear el Bot en Telegram. Para crear el Bot, abriremos una conversación con el gestor de bots @BotFather y escribiremos los siguientes comandos:

/start
/newbot
MyMikroTikMessagesBot

 

 

Una vez creado el Bot, se nos entregará un ID y un Token de acceso que deberemos guardar en lugar seguro para poder usar nuestro Bot:

Enviar Mensajes Telegram desde Mikrotik@BotFather

 

 

Ahora crearemos un grupo normal en Telegram, por ejemplo "MikroTikMessagesGroup" y meteremos en dicho grupo al bot "MyMikroTikMessagesBot":

Enviar Mensajes Telegram desde MikrotikCrear canal y añadir el Bot

 

 

En la siguiente imagen se ve como el bot ha sido añadido al canal:

Enviar Mensajes Telegram desde MikrotikBot añadido al Grupo Telegram

3.- SCRIPT DE NOTIFICACIÓN A TELEGRAM

Ahora crearemos el script en el MikroTik desde "System->Scripts":

Enviar Mensajes Telegram desde MikrotikMenú scripts

 

 

Para crear el script, desde la pestaña "Scripts" haremos click en +:

Enviar Mensajes Telegram desde MikrotikMikroTik Telegram

 

 

El código del script es el siguiente (tenéis que usar vuestro ID y Token):

:local botTelegramToken "1680595166:AAF2AGFdPdC5AIvDg1Dg1-G1z-3h4uZOlH4";
:local telegramChatID "-593484444";
:local parseMode "html";
:local disablePreview True;
:local textToSend "THIS IS AN ALERT FROM MIKROTIK";

:local telegramUrl "https://api.telegram.org/bot$botTelegramToken/sendMessage?chat_id=$telegramChatID&text=$textToSend&parse_mode=$parseMode&disable_web_page_preview=$disablePreview";

/tool fetch http-method=get url=$telegramUrl;

:log info "Send Telegram Message";

 

 

En la siguiente imagen se ve el nombre del script "AlertsToTelegram", los permisos necesarios "read" y abajo el script. Una vez finalizado pulsaremos "OK":

Enviar Mensajes Telegram desde MikrotikMikroTik Telegram

 

 

En la lista de scripts se verá el script creado y el número de veces ejecutado:

Enviar Mensajes Telegram desde MikrotikLista de Scripts MikroTik

 

 

4.- PROBAR EL SCRIPT DE FORMA MANUAL

Para probar el script, ejecutaremos el siguiente comando. El script no debe mostrar ningún error, tal y como se ve a continuación:

[admin@MikroTik] > /system script run AlertsToTelegram
status: finished
downloaded: 0KiBC-z pause]
total: 0KiB
duration: 0s

 

 

En la siguiente imagen se ve como el mensaje ha llegado correctamente al grupo creado utilizando nuestro Bot.

Enviar Mensajes Telegram desde MikrotikMikroTik Telegram

  

 

ENJOY!


Raúl Prieto Fernández

Sitio Web: raulprietofernandez.net

Si quieres ir rápido, ve solo. Si quieres llegar lejos, ve acompañado.

Escribir un comentario

Código de seguridad
Refescar